[kde-freebsd] dbus-qt4 dependency on qt4-gui

John Prather john.c.prather at gmail.com
Mon Aug 29 06:19:33 UTC 2011

FreeBSD KDE crew,

Seems devel/dbus-qt4/ was mistakenly given the dependency of the gui
component of qt.

This of course causes havoc when trying to use dbus-qt4 on a server,
as it brings in a good deal of X11 packages that should not be needed
on a server.

I would have submitted a "fix" patch but I'm not sure that simply
removing "gui" from the required components for the port won't cause
something else which requires gui but doesn't specify it as a
dependency to break.   So I figured it wisest to leave the solution in
the hands of those who know QT like the back of their hands.



More information about the kde-freebsd mailing list