[kde-freebsd] Found qt4-qmake-4.4.1, but you need to upgrade to qt4-qmake>=4.4.3

Max Brazhnikov makc at issp.ac.ru
Tue Feb 24 10:57:45 CET 2009

On Sun, 22 Feb 2009 04:34:50 -0500, Mikhail T. wrote:
> Max Brazhnikov написав(ла):
> > I can't say it will really break something (at least for different
> > revisions), however having mixed qt4 parts of several versions is not
> > supposed. Qt provides single package for qt4 and it doesn't support by
> > component build. While our ports allow to build qt4 by parts, it's
> > primary for reducing the total qt4 components installed.
> The following tiny patch relaxes the current requirements a little bit
> -- and makes the use of ">=" a little more sensible -- by demanding,
> only the major and the minor version numbers match, but not necessarily
> the micro. It will still be impossible to use qmake-4.4.3 to build
> qt-4.5.x, but it is an improvement over the current situation...
> Longer term, qmake (and possibly, some other components) may need to be
> treated separately from the rest of the Qt4-components to apply even
> more relaxed requirements to them.
> Yours,
>     -mi
If we are going to relax the requirements, I'd like to not stop halfway and 
convert qt.mk to use usual lib/run/build dependencies. I'll do it with next 
qt4 update.


More information about the kde-freebsd mailing list