[kde-freebsd] Found qt4-qmake-4.4.1, but you need to upgrade to qt4-qmake>=4.4.3

Max Brazhnikov makc at issp.ac.ru
Sun Feb 22 09:14:48 CET 2009

On Sat, 21 Feb 2009 19:48:54 -0500, Mikhail T. wrote:
> Hi, I wanted to save some time upgrading my Qt4 installation and did not
> delete the qmake4 port. Unfortunately, the version-checker is very strict:
>     ===>   qt4-gui-4.4.3_1 depends on package: qt4-qmake>=4.4.3 - not found
>     ===>   Found qt4-qmake-4.4.1, but you need to upgrade to
>     qt4-qmake>=4.4.3.
>     *** Error code 1
> Will the thing really break with the earlier qmake4, or is this, in
> fact, an over-kill? Thanks,
I can't say it will really break something (at least for different revisions), 
however having mixed qt4 parts of several versions is not supposed. Qt 
provides single package for qt4 and it doesn't support by component build.
While our ports allow to build qt4 by parts, it's primary for reducing the 
total qt4 components installed.


More information about the kde-freebsd mailing list