[kde-freebsd] mouse pointer woes SOLVED

David Southwell david at vizion2000.net
Mon Jul 21 18:37:25 CEST 2008


> -----Original Message-----
> From: David Southwell [mailto:david at vizion2000.net] 
> Sent: 21 July 2008 07:15
> To: kde-freebsd at kde.org
> Subject: [kde-freebsd] mouse pointer woes
> I am now finding the mouse pointer failing intermitently. The 
> only way to restore mouse functionality is by a reboot. Ctrl 
> Alt Backspace followed by startx does not restore pointer 
> functionality. After boot up kde runs fine then without warning:
> The mouse continues to function all the time But no visible 
> pointer on the screen!!!. If the mouse moved and, guess where 
> it is then click/double click work just fine.
> FreeBSD ***.vizion2000.net 7.0-STABLE FreeBSD 7.0-STABLE #0: 
> Wed Jul 16 
> 09:27:38 PDT 2008     
> ****@****.vizion2000.net:/usr/obj/usr/src/sys/GENERIC  
> amd64
> Just upgraded from 6.3 to 7.0
> Any ideas where to begiin looking? 
> Thanks in advance
> David

Found the solution.
a. I found it only happens when X windows went to sleep. The solution seems
to be:

Change xorg.conf line in Options to read:
"HWCursor" "False"

startx worked fine.
I have net had this happen on the same machine for years until after I
upgraded from freebsd 6.3 to 7.0. Incidentally the graphics card is nvidia


More information about the kde-freebsd mailing list