[kde-freebsd] KDE Base will not build on FreeBSD 6.2

Brett Wynkoop wynkoop at cs.stevens.edu
Wed Nov 28 02:10:15 CET 2007


I am trying to build kde base, really kdelite, on FreeBSD 6.2 with ports
cvsuped as of TODAY and this is what I get:

/usr/local/bin/moc ./progressdialog.h -o progressdialog.moc
c++ -DHAVE_CONFIG_H -I. -I.. -I/usr/local/include  -I/usr/local/include  -D_THREAD_SAFE -pthread -DQT_THREAD_SUPPORT   -I/usr/local/include -I/usr/local/include  -I/usr/local/include -D_GETOPT_H -D_THREAD_SAFE  -D_LARGE_FILES=1  -Wno-long-long -Wundef -Wall -W -Wpointer-arith -DNDEBUG -DNO_DEBUG -O2 -O2 -fno-strict-aliasing -pipe -Wno-non-virtual-dtor -fno-exceptions -fno-check-new -fno-common -DQT_CLEAN_NAMESPACE -DQT_NO_ASCII_CAST -DQT_NO_STL -DQT_NO_COMPAT -DQT_NO_TRANSLATION -D_GNU_SOURCE -DQT_NO_CAST_ASCII -DQT_NO_ASCII_CAST -MT progressdialog.o -MD -MP -MF .deps/progressdialog.Tpo -c -o progressdialog.o progressdialog.cpp
progressdialog.cpp: In member function `virtual void ProgressDialog::ignoreCancel()':
progressdialog.cpp:90: error: `ignoreCancel' is not a member of `KProgressDialog'
gmake[2]: *** [progressdialog.o] Error 1
gmake[2]: Leaving directory `/export/ports/x11/kdebase3/work/kdebase-3.5.8/kdialog'
gmake[1]: *** [all-recursive] Error 1
gmake[1]: Leaving directory `/export/ports/x11/kdebase3/work/kdebase-3.5.8'
gmake: *** [all] Error 2
*** Error code 2

Stop in /export/ports/x11/kdebase3.
*** Error code 1

Stop in /export/ports/x11/kdebase3.
beastly# ls

Here is a little more info:

beastly# uname -a
FreeBSD beastly.cs.stevens.edu 6.2-RELEASE FreeBSD 6.2-RELEASE #0: Fri Nov 23 19:00:40 EST 2007     wynkoop at beastly.cs.stevens.edu:/usr/src/sys/i386/compile/BIGDATA  i386

This same thing happened about 3 weeks ago.  I did not try to build kdebase3
before I cvsuped the ports tree as I wanted the lattest of everything
and I did not want to go through the trouble involved with the upgrade from
X11R6 to X11R7.  The build system started off as a kern developer install
with ports.  The first thing installed after that was cvsup.  The ports
tree was then updated to current and X11 was built and installed.  Every
other X application or window manager I have tried to build from ports
has just worked.  I found many references to kdebase3 being broken in
FreeBSD going back to 4.x.  This is my first time trying to build KDE as
I do not use it myself, but some of my users have requested it.

Any clues or pointers would be appreciated!


More information about the kde-freebsd mailing list