[kde-freebsd] Trunk on FreeBSD

Manolo Valdes nolis71cu at gmail.com
Sat May 19 21:56:57 CEST 2007

El Saturday 19 May 2007 11:41:26 am Philip Rodrigues escribió:
> Hi kde-freebsd (and Ade, specifically),
> I've just built some of trunk on FreeBSD, and noticed several issues. I was
> wondering if anyone had seen the same, or had any insight. I've managed to
> work around all of them, but I suppose at least some of them are/could be
> real porting issues, rather than just me being stupid, so here goes:
> Problem:
> 	The kDebugBackend function in kdelibs/kdecore/io has some weird thread
> issue . There's a warning in the file that it isn't threadsafe, and one of
> mkretz's commits says that the current solution is temporary, so I suppose
> this could be an actual problem. The exact behaviour I see is that apps (eg
> kbuildsycoca4) just "stop" - no CPU usage, no output. Attaching gdb and
> getting a bt just gives a handful of pthread_* calls. However, there's
> another thread running, which has the actual KDE calls in.
> Workaround:
> 	I just added a "return" at the beginning of that function, so it doesn't
> do anything. Means I get no debug output, but at least apps do *something*
> Problem:
> 	kbuildsycoca4 hangs with 100% CPU in the following circumstance: a
> .desktop file is found containing a [$e] entry (ie, execute a command to
> get the value for this config option). The specific instances are
> $KDEDIR/share/services/randr.desktop and xinerama.desktop. The hang occurs
> at kdelibs/kdecore/config/kconfiggroup.cpp:316. It looks as if QTextStream
> isn't reading the EOL properly, and keeps reading the stream infinitely; 
> but a little test program works fine. I suspect this one might be a local
> problem.
> Workaround:
> 	Delete randr.desktop and xinerama.desktop
> Problem:
> 	Something (KLibLoader?) tries to open $KDEDIR/lib/kde4/libkio_kfile.so
> when the actual file is kio_kfile.so (no preceding "lib"). I suspect a
> local problem.
> Workaround:
> 	Create symlinks
> Problem:
> 	(May be related to the previous problem). Running dolphin or konqueror
> results in:
> QLibrary::load_sys: Cannot load
> /usr/home/kdedev/install/lib/kde4/kio_file.so (Shared object
> "libQtCore.so.4" not found, required by "libkio_file.so")
> which is odd, because the directory containing libQtCore is in
> LD_LIBRARY_PATH. It seems like klauncher isn't getting the environment
> correctly.
> Workaround:
> uname -a says:
> FreeBSD hazelrah 6.0-STABLE FreeBSD 6.0-STABLE #2: Tue Jan  3 11:00:10 GMT
> 2006     root at hazelrah:/usr/obj/usr/src/sys/HAZELRAH  i386
> Hope some of this is useful to someone. I'm happy to report things upstream
> to kde-core-devel if anyone thinks some of these could be real porting
> errors.

I already ask this issue of kio_file on irc #kde4-devel
and no one reply me. so i guess it is a freeBSD only issue. it is happening 
since 10 days ago or so. now i'm not sure if it is due some kdelibs bug or 
qt4 one. the fact is that  kio_file dont works :(


> Regards,
> Philip

Todo lo puedo en Cristo que me fortalece
Filipenses. 4:13
I can do all things through Christ who strengthens me.
Philippians 4:13

More information about the kde-freebsd mailing list