D28882: Create protocol to manage video feeds
Vlad Zahorodnii
noreply at phabricator.kde.org
Mon Apr 27 18:34:18 BST 2020
zzag requested changes to this revision.
zzag added a comment.
This revision now requires changes to proceed.
> In future, it might be faster to put up just the interface xml for review first.
++
---
What about using existing `wl_output` objects? The `add_source` event can be simplified quite a lot (even maybe dropped). For windows, we could use string handles.
<request name="record_monitor">
<description/>
<arg name="id" type="new_id" interface="zkde_screencast_stream_v1"/>
<arg name="output" type="object" interface="wl_output"/>
</request>
<request name="record_window">
<description/>
<arg name="id" type="new_id" interface="zkde_screencast_stream_v1"/>
<arg name="handle" type="string"/>
</request>
Please notice that the manager object also needs to advertise supported cursor modes
<enum name="cursor_mode">
<entry name="hidden" value="0"
summary="the cursor is not part of the screen cast stream"/>
<entry name="metadata" value="1"
summary="the cursor is not part of the screen cast stream, but sent as PipeWire metadata"/>
<entry name="embedded" value="2"
summary="the cursor is embedded as part of the stream buffers"/>
</enum>
<event name="cursor_mode">
<description summary="blah-blah"></description>
<arg name="mode" type="uint" enum="cursor_mode" summary="supported cursor mode"/>
</event>
INLINE COMMENTS
> screencast.xml:8
> + ]]></copyright>
> + <interface name="zkde_screencast_unstable_v1" version="1">
> + <description summary="Protocol for managing Pipewire feeds of the different displays and windows."/>
Interfaces usually come without `unstable` in the name.
s/zkde_screencast_unstable_v1/zkde_screencast_v1/
> screencast.xml:52-54
> + <request name="close">
> + <description summary="requests closing a pipewire buffer"/>
> + </request>
zkde_screencast_stream_unstable_v1 must have a destructor request.
REPOSITORY
R127 KWayland
REVISION DETAIL
https://phabricator.kde.org/D28882
To: apol, #kwin, jgrulich, davidedmundson, zzag
Cc: meven, davidedmundson, romangg, zzag, kde-frameworks-devel, LeGast00n, cblack, michaelh, ngraham, bruns
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kde-frameworks-devel/attachments/20200427/0ae53109/attachment-0001.html>
More information about the Kde-frameworks-devel
mailing list