D7841: kioexec: Do not start to watch a temporary copy until after the copy is complete

David Faure noreply at phabricator.kde.org
Sun Sep 24 11:06:45 UTC 2017


dfaure accepted this revision.
dfaure added a comment.
This revision is now accepted and ready to land.


  Makes sense.

INLINE COMMENTS

> main.cpp:151
> +            for (; it != fileList.end(); ++it) {
> +                if (it->path == path) {
> +                    break;

(pre-existing) std::find_if with a lambda would be shorter and (imho) more readable, but feel free to ignore this if you're not at ease with that

> main.cpp:166
> +            const QString dest = copyJob->srcUrl().toString();
> +            qDebug() << "path" << path;
> +            qDebug() << "dest" << dest;

clean up the debug output please

REPOSITORY
  R241 KIO

REVISION DETAIL
  https://phabricator.kde.org/D7841

To: marten, #frameworks, dfaure
Cc: elvisangelaccio, dfaure
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kde-frameworks-devel/attachments/20170924/ff1cec24/attachment.html>


More information about the Kde-frameworks-devel mailing list