[Differential] [Accepted] D4003: Fix "byte order marker" -> "byte order mark", use upper-case "Unicode" name
dhaumann (Dominik Haumann)
noreply at phabricator.kde.org
Sun Jan 8 11:31:32 UTC 2017
dhaumann accepted this revision.
dhaumann added a reviewer: dhaumann.
dhaumann added a comment.
This revision is now accepted and ready to land.
Two thinkgs:
1. Please address the comments from Christoph and myself
2. Please adapt in kate.git: kate/docs/
INLINE COMMENTS
> katedocument.cpp:4587
> } else if (var == QLatin1String("bom") || var == QLatin1String("byte-order-marker")) {
> + // TODO: byte-order-marker is misnomer, should be byte-order-mark
> if (checkBoolValue(val, &state)) {
Yes, please add backwards compatibility:
} else if (var == QLatin1String("bom") || var == QLatin1String("byte-order-mark") || var == QLatin1String("byte-order-marker")) {
> variablelineedit.cpp:162
>
> // Add 'byte-order-marker' (bom) to list
> item = new VariableBoolItem(QStringLiteral("byte-order-marker"), docConfig->bom());
rename comment to "byte-order-mark"
> variablelineedit.cpp:163
> // Add 'byte-order-marker' (bom) to list
> item = new VariableBoolItem(QStringLiteral("byte-order-marker"), docConfig->bom());
> + item->setHelpText(i18nc("short translation please", "Enable the byte order mark (BOM) when saving Unicode files."));
Rename to "byte-order-mark"
REPOSITORY
R39 KTextEditor
BRANCH
alignNamingOfBOFandUnicode
REVISION DETAIL
https://phabricator.kde.org/D4003
EMAIL PREFERENCES
https://phabricator.kde.org/settings/panel/emailpreferences/
To: kossebau, #kate, dhaumann
Cc: dhaumann, cullmann, kwrite-devel, #frameworks
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kde-frameworks-devel/attachments/20170108/90997278/attachment.html>
More information about the Kde-frameworks-devel
mailing list