Review Request 117010: Finish renames in KCoreConfigSkeleton, and stop doing extra loads as well.

Alexander Richardson arichardson.kde at googlemail.com
Mon Mar 24 00:11:22 UTC 2014



> On March 24, 2014, 12:22 a.m., David Faure wrote:
> > src/core/kcoreconfigskeleton.cpp, line 1112
> > <https://git.reviewboard.kde.org/r/117010/diff/1/?file=256493#file256493line1112>
> >
> >     Won't this break with MSVC?

Shouldn't break MSVC, it will just give a unknown pragma warning.
Nevertheless it should be in a Q_CC_GNU block.


- Alexander


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://git.reviewboard.kde.org/r/117010/#review53876
-----------------------------------------------------------


On March 24, 2014, 12:11 a.m., Matthew Dawson wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://git.reviewboard.kde.org/r/117010/
> -----------------------------------------------------------
> 
> (Updated March 24, 2014, 12:11 a.m.)
> 
> 
> Review request for KDE Frameworks and David Faure.
> 
> 
> Repository: kconfig
> 
> 
> Description
> -------
> 
> Stop re-loading values inside KCoreConfigSkeleton::save().
> 
> The extra load of values in KCoreConfigSkeleton is not documented anywhere
> that it happens, and in normal circumstances re-loading new values isn't
> expecterd during a save operation.
> 
> Update various mentions of readConfig/writeConfig to read/save.
> 
> Update documentation to match the new names of functions.
> 
> Rename writeConfig() to save() and usrWriteConfig() to usrSave()
> 
> Rename functions to match the new naming conventions.  Also create old deprecated
> instances of both functions to ensure that old code continues to operate
> correctly.  Also make save() non-virtual, for the same reasons read() is
> now non-virtual.
> 
> Rename usrReadConfig to usrRead, to be consistent with the new name for readConfig.
> 
> Rename usrReadConfig to usrRead, and mark the former as deprecated.  To maintain
> compatibility, usrRead still calls usrReadConfig in its default implementation.
> usrReadConfig remains empty.
> 
> 
> Diffs
> -----
> 
>   src/gui/kconfigskeleton.h 8262f5ce642895c94eda5cde7091fdfbc2c8a7b2 
>   src/core/kcoreconfigskeleton.cpp 69a4bf0405b985378976d67ee3774e043fe513db 
>   src/core/kcoreconfigskeleton.h 41f1428987b80bd842b7d46720251e3f4d13c86e 
>   autotests/kconfigskeletontest.cpp a25aaf40e9b58d2947e6ea89aa8d5024d8981da4 
>   autotests/kconfig_compiler/kconfigcompiler_test_signals.cpp 3017fe2f7bd081719ba4c7cb3867c345e97b3bcb 
> 
> Diff: https://git.reviewboard.kde.org/r/117010/diff/
> 
> 
> Testing
> -------
> 
> Unit tests continue to pass.
> 
> 
> Thanks,
> 
> Matthew Dawson
> 
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kde-frameworks-devel/attachments/20140324/c01ae775/attachment.html>


More information about the Kde-frameworks-devel mailing list