Review Request 118514: Add KColumnResizer to KWidgetsAddons
Aurélien Gâteau
agateau at kde.org
Wed Jun 4 12:42:40 UTC 2014
> On June 4, 2014, 1:41 p.m., Dominik Haumann wrote:
> > src/kcolumnresizer.cpp, line 200
> > <https://git.reviewboard.kde.org/r/118514/diff/2/?file=278585#file278585line200>
> >
> > You can use auto here, if wanted (you can use auto much more often in your patch, btw.):
> >
> > if (auto gridLayout = qobject_cast<QGridLayout*>(layout)) {
> > d->addWidgetsFromGridLayout(gridLayout, column);
> > return;
> > }
> >
> > if (auto formLayout = qobject_cast<QGridLayout*>(layout)) {
> > // ...
> > }
I am not fond of declaring variables inside the condition part of an if: I find those harder to read.
- Aurélien
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://git.reviewboard.kde.org/r/118514/#review59170
-----------------------------------------------------------
On June 4, 2014, 11:52 a.m., Aurélien Gâteau wrote:
>
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://git.reviewboard.kde.org/r/118514/
> -----------------------------------------------------------
>
> (Updated June 4, 2014, 11:52 a.m.)
>
>
> Review request for KDE Frameworks and Christoph Feck.
>
>
> Repository: kwidgetsaddons
>
>
> Description
> -------
>
> I have been asked to add ColumnResizer to KWidgetAddons. ColumnResizer is a helper class I created long ago to help maintain uniform widths across layouts. You can learn more about it from the blog post I wrote back then: http://agateau.com/2011/clean-up-your-layouts-with-columnresizer/ . I simplified the API a bit, added some documentation, and here it is.
>
>
> Diffs
> -----
>
> src/CMakeLists.txt 27b9084
> src/kcolumnresizer.h PRE-CREATION
> src/kcolumnresizer.cpp PRE-CREATION
> tests/CMakeLists.txt eccf887
> tests/kcolumnresizertest.h PRE-CREATION
> tests/kcolumnresizertest.cpp PRE-CREATION
> tests/kcolumnresizertest.ui PRE-CREATION
>
> Diff: https://git.reviewboard.kde.org/r/118514/diff/
>
>
> Testing
> -------
>
> Manual test program behaves as expected.
>
>
> Thanks,
>
> Aurélien Gâteau
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kde-frameworks-devel/attachments/20140604/4a83d2fc/attachment-0001.html>
More information about the Kde-frameworks-devel
mailing list