kcoreaddons fails to build properly on OSX/CI (was OSX/CI: kauth fails to build )

Marko Käning mk-lists at email.de
Tue Aug 19 21:09:06 UTC 2014

Hi Aleix & Ben,

On 13 Aug 2014, at 10:51 , Aleix Pol <aleixpol at kde.org> wrote:
> I'm unsure, try cleaning the build directory and trying again?
> There certainly hasn't been a change on the kf5 side, that I know of at least.

following you guys’ advice, I could verify that there was nothing new, neither in
ECM nor in kcoreaddons.

Although I had *UN*successfully tried to build tier 2 from scratch a week ago, I
tried again today and see, now it worked! :-|
So, this must have been caused by the build directory itself for some reason.
(But I haven’t tried to figure out why this had happened, due to lack of insight
into these builds…)

For now I am happy that the CI scripts should be able to build most KF5 frameworks
once again now, at least as long as I keep using my old Qt5!!
I haven’t tried to build project qt5 since [1], which is an issue into which also
Thibaut ran at Randa and which we could only fix by reverting back to an older qt5
install going back to June 10th.


[1] http://mail.kde.org/pipermail/kde-frameworks-devel/2014-August/018268.html
[2] qt5 - a83826dad0f62d7a96f5a6093240e4c8f7f2e06e

More information about the Kde-frameworks-devel mailing list