Review Request 107973: Cleanup : Move all gesture facilities of KAction in KGestureMap

Kevin Ottens ervin at kde.org
Mon Jan 14 21:24:27 UTC 2013


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
http://git.reviewboard.kde.org/r/107973/#review25523
-----------------------------------------------------------


It's really getting close now. Mostly comments on the coding style, it's a very good sign. :-)


kdeui/actions/kaction.h
<http://git.reviewboard.kde.org/r/107973/#comment19495>

    Still that change to revert.



kdeui/dialogs/kshortcutseditoritem.cpp
<http://git.reviewboard.kde.org/r/107973/#comment19496>

    Remove the space after ( and before )



kdeui/dialogs/kshortcutseditoritem.cpp
<http://git.reviewboard.kde.org/r/107973/#comment19497>

    I think you meant setDefaultGesture here.



kdeui/shortcuts/kgesturemap.h
<http://git.reviewboard.kde.org/r/107973/#comment19507>

    I would rename to setShapeGesture to get symmetry with the getter.



kdeui/shortcuts/kgesturemap.h
<http://git.reviewboard.kde.org/r/107973/#comment19508>

    I would rename to setRockerGesture to get symmetry with the getter.



kdeui/shortcuts/kgesturemap.h
<http://git.reviewboard.kde.org/r/107973/#comment19509>

    I would rename to setDefaultShapeGesture to get symmetry with the getter.



kdeui/shortcuts/kgesturemap.h
<http://git.reviewboard.kde.org/r/107973/#comment19510>

    I would rename to setDefaultRockerGesture to get symmetry with the getter.



kdeui/shortcuts/kgesturemap.cpp
<http://git.reviewboard.kde.org/r/107973/#comment19498>

    In the whole code of this method please remove spaces after ( and before )



kdeui/shortcuts/kgesturemap.cpp
<http://git.reviewboard.kde.org/r/107973/#comment19499>

    In the whole code of this method please remove spaces after ( and before )



kdeui/shortcuts/kgesturemap.cpp
<http://git.reviewboard.kde.org/r/107973/#comment19503>

    Split the condition on several lines. Also get the call of constEnd() out of the loop



kdeui/shortcuts/kgesturemap.cpp
<http://git.reviewboard.kde.org/r/107973/#comment19500>

    In the whole code of this method please remove spaces after ( and before )



kdeui/shortcuts/kgesturemap.cpp
<http://git.reviewboard.kde.org/r/107973/#comment19502>

    Split the condition on several lines. Also get the call of constEnd() out of the loop



kdeui/shortcuts/kgesturemap.cpp
<http://git.reviewboard.kde.org/r/107973/#comment19501>

    In the whole code of this method please remove spaces after ( and before )



kdeui/shortcuts/kgesturemap.cpp
<http://git.reviewboard.kde.org/r/107973/#comment19504>

    Split the condition on several lines. Also get the call of constEnd() out of the loop



kdeui/shortcuts/kgesturemap.cpp
<http://git.reviewboard.kde.org/r/107973/#comment19506>

    In the whole code of this method please remove spaces after ( and before )



kdeui/shortcuts/kgesturemap.cpp
<http://git.reviewboard.kde.org/r/107973/#comment19505>

    Split the condition on several lines. Also get the call of constEnd() out of the loop


- Kevin Ottens


On Jan. 4, 2013, 9:18 p.m., Valentin Rusu wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> http://git.reviewboard.kde.org/r/107973/
> -----------------------------------------------------------
> 
> (Updated Jan. 4, 2013, 9:18 p.m.)
> 
> 
> Review request for KDE Frameworks and Kevin Ottens.
> 
> 
> Description
> -------
> 
> This changeset removes all gesture facilities from KAction and define them in KGestureMap. Thanks for the feedback.
> 
> 
> Diffs
> -----
> 
>   KDE5PORTING.html 86dfc1a 
>   kdeui/actions/kaction.h f45c94d 
>   kdeui/actions/kaction.cpp b78d1d6 
>   kdeui/actions/kaction_p.h f87272c 
>   kdeui/dialogs/kshortcutseditor.cpp 5653984 
>   kdeui/dialogs/kshortcutseditoritem.cpp e85a203 
>   kdeui/shortcuts/kgesturemap.h 56b42b6 
>   kdeui/shortcuts/kgesturemap.cpp 1350dbe 
> 
> Diff: http://git.reviewboard.kde.org/r/107973/diff/
> 
> 
> Testing
> -------
> 
> Code builds OK. KGestureMap is not actually used, though, as KGestureMap::eventFilter method return false right away.
> 
> 
> Thanks,
> 
> Valentin Rusu
> 
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kde-frameworks-devel/attachments/20130114/0e5fa071/attachment-0001.html>


More information about the Kde-frameworks-devel mailing list