Porting KWidgets to Qt5
David Faure
faure at kde.org
Mon Jul 9 15:40:38 UTC 2012
On Monday 09 July 2012 18:05:07 Иван Комиссаров wrote:
> Ok, if KDE devs can live without tis signal, i can live too. However we
> could just rename it to something less specific than 'newTabrequested" but
> not confusing with doublClicked().
And we can also add an if() in the apps when porting them away from KTabBar
(and renaming the signal and slots anyway), no big deal.
> So, before i start other work with tabbar i would like to ask some
> questions.
> 1) I can add property "autoHideTabBar" to hide it when tab count is equal
> or less than 1. Is it needed?
Yes this seems very commonly used.
http://lxr.kde.org/ident?i=setTabBarHidden
> Should it be added to both QTabBar and QTabWidget?
I guess so, although if it's deemed too corner-case then having it in QTabBar
only is good enough (now that tabBar() is public).
> 2) I can add property "switchTabsOnDrag" to allow automatically changing
> tabs when user drags something over it. Is it needed?
Interesting, KTabBar seems to do this by default, without even an option to
turn it off? I wonder if this means QTabBar should do the same, or if it should
indeed be enabled explicitely. I'm not sure if there's a use case for *not*
doing it (especially with a timer, like in KTabBar, so that stuff doesn't jump
around all the time).
I would try to implement this without a property first, or to ask on the qt
development list whether anyone would object.
But of course a property is fine with me too.
--
David Faure, faure at kde.org, http://www.davidfaure.fr
Sponsored by Nokia to work on KDE, incl. KDE Frameworks 5
More information about the Kde-frameworks-devel
mailing list