version # in frameworks

Stephen Kelly steveire at
Tue Dec 6 20:12:00 UTC 2011

Kevin Ottens wrote:

> On Sunday 04 December 2011 23:53:14 Aaron J. Seigo wrote:
>> this should be bumped imho to reflect that this is the "5.0" version.
>> should we do the usual "4.90"?
> Sounds good to me, I even stupidly assumed it was already the case but
> didn't check. :-)
> Regards.

Currently all frameworks, being disconnected from a global dependency to 
provide a version number, use a cmake macro something like:

ecm_version(5 0 0)

I imagined that such a thing could be modified by a script when needed by 
scripty or the release process.

At the moment though I think the problem of setting version information for 
all frameworks is an open one.



More information about the Kde-frameworks-devel mailing list