Review Request: Normalizing SIGNAL and SLOT signatures
Laszlo Papp
lpapp at kde.org
Fri Jan 11 19:04:32 UTC 2013
> On Jan. 1, 2013, 8:10 p.m., Laszlo Papp wrote:
> > IMO, this will be pointless and less readable with Qt5. It is ok for Qt4, though.
>
> Kevin Krammer wrote:
> Interesting. Qt5 doesn't need to parse method signatures anymore?
> What purpose does QMetaObjectPrivate::decodeMethodSignature() have if not parsing the method signature?
>
> Laszlo Papp wrote:
> As far as I understood the check can be done compilation time with Qt5 (and C++11?), and not runtime.
>
> Kevin Krammer wrote:
> No, only for the new-style connects, when using member functions, functors or lambda expression.
> The macro style signal/slot connection is still runtime checked.
Yeah, that is what I meant with Qt5 and C++11, and we should switch to that as much as possible. :)
On the other hand, even with the old form, read this: http://lists.kde.org/?l=kde-core-devel&m=132920536226618&w=2
I agree with Ossi about this because if it is a bottleneck, it is just bad since it should not, and it also makes the readability worse without the separators. :)
- Laszlo
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
http://git.reviewboard.kde.org/r/108053/#review24382
-----------------------------------------------------------
On Dec. 31, 2012, 4:25 p.m., Mayank Madan wrote:
>
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> http://git.reviewboard.kde.org/r/108053/
> -----------------------------------------------------------
>
> (Updated Dec. 31, 2012, 4:25 p.m.)
>
>
> Review request for KDE Edu and Kevin Krammer.
>
>
> Description
> -------
>
> Fixing SIGNAL/SLOT signatures to normalized form as reported by Krazy
>
>
> Diffs
> -----
>
> src/plugins/render/graticule/GraticulePlugin.cpp 00e69b9
> src/plugins/render/positionmarker/PositionMarker.cpp e18c047
> src/plugins/render/satellites/SatellitesConfigDialog.cpp ce1f211
> src/plugins/render/satellites/SatellitesPlugin.cpp 551aef3
> src/plugins/render/speedometer/Speedometer.cpp 35eca7b
>
> Diff: http://git.reviewboard.kde.org/r/108053/diff/
>
>
> Testing
> -------
>
>
> Thanks,
>
> Mayank Madan
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kde-edu/attachments/20130111/b1260c5c/attachment-0001.html>
More information about the kde-edu
mailing list