[kde-edu]: KTouch bug in keyboard editor

Arnaud DUPUIS a.dupuis at infinityperl.org
Sun Dec 30 19:12:57 CET 2007


Following the KTouch quality check i tried to solve and patch the bug :

I tried... and it's not a success. I think the problem is not in KTouch, i 
added a kDebug() output just before calling the buggy KFileDialog call and 
the KUrl is just fine :

From the output on my konsole, and the quick look i had to the KFileDialog 
code, i think the bug is in the kio part but i'm not sure yet. I will have a 
look at this later. 
Maybe somebody already ran into this situation. From what i saw, it looks like 
the extension of the file (here .xml) is replace by the non-general part of 
the filter (here keyboard.xml). I have no idea where it is done and if it's 
actually the problem, but it look like that.

See you later.



[ Infinity Perl ]

"Slackware : because it works"
slack-get : because it rocks !
gpg id : 0xAC37E1B0
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part.
Url : http://mail.kde.org/pipermail/kde-edu/attachments/20071230/929f6d82/attachment.pgp 

More information about the kde-edu mailing list