[kde-edu]: KVocTrain vs KWordQuiz -- vocabulary trainers in general

Daniel Klein bringa at gmx.at
Mon Mar 29 15:39:17 CEST 2004

Alright, thanks to Matthias already for the help so far, now I've run across 
another problem - I need qt 3.2 or higher, while I have qt 3.0.4 installed. I 
downloaded qt 3.3.1 from trolltech.org (maybe this wasn't the most clever 
thing to do? Could I have done that by simply getting KDE devel libs 
somewhere?) and tried to compile it, but I run into this weird error:

g++ -o qmake project.o property.o main.o makefile.o unixmake2.o unixmake.o 
msvc_nmake.o borland_bmake.o mingw_make.o msvc_dsp.o msvc_vcproj.o option.o 
winmakefile.o projectgenerator.o metrowerks_xml.o  pbuilder_pbx.o 
msvc_objectmodel.o meta.o qtmd5.o qstring.o qtextstream.o qiodevice.o 
qglobal.o qgdict.o qcstring.o qdatastream.o qgarray.o qbuffer.o qglist.o 
qptrcollection.o qfile.o qfile_unix.o qregexp.o qgvector.o qgcache.o 
qbitarray.o qdir.o quuid.o qfileinfo_unix.o qdir_unix.o qfileinfo.o 
qdatetime.o qstringlist.o qmap.o qconfig.o qunicodetables.o qsettings.o 
project.o: In function `QMakeProject::parse(QString const&, QMap<QString, 
project.o(.text+0x2b57): undefined reference to `atexit'
makefile.o: In function `MakefileGenerator::buildArgs()':
makefile.o(.text+0x20e64): undefined reference to `atexit'
makefile.o: In function `MakefileGenerator::build_args()':
makefile.o(.text+0x21512): undefined reference to `atexit'
metrowerks_xml.o: In function 
`MetrowerksMakefileGenerator::fixifyToMacPath(QString&, QString&, bool)':
metrowerks_xml.o(.text+0xa9af): undefined reference to `atexit'
qlocale.o: In function `QLocalePrivate::systemLocaleName()':
qlocale.o(.text+0x412): undefined reference to `atexit'
collect2: ld returned 1 exit status
gmake: *** [qmake] Error 1
qmake failed to build. Aborting.

Should I go find a qt mailinglist to bug those guys about it? Or is there a 
simpler way for me to get a new qt?


More information about the kde-edu mailing list