Grantlee latest 5.2.0 and deprecated QString enums in its API

Friedrich W. H. Kossebau kossebau at kde.org
Mon Dec 28 17:07:07 GMT 2020


Hi Steve & all Grantlee consumers,

TL;DR  Current last release 5.2.0 of Grantlee blocks applications from using 
QT_DISABLE_DEPRECATED_BEFORE=0x050F00., Please let's have a new release 
5.3.0/5.2.1 of Grantlee with a fix for that (MR 70 up as proposal)


Some of us have hit the issue that Grantlee also in its latest released 
version 5.2.0 uses at least one deprecated Qt enum in its public API 
(QString::SplitBehavior in SafeString methods).
Which then makes it impossible in own software using Grantlee to enforce the 
invisibility of deprecated Qt API using QT_DISABLE_DEPRECATED_BEFORE with a 
version of 5.15 (0x050F00).

While the master branch of Grantlee has a first approach to that, that one has 
some issues though. Thus a few days ago I created a MR for Grantlee which 
should fix those issues:
    https://github.com/steveire/grantlee/pull/70

Please have a look at the MR and give that some testing/review.
I hope you Steve could do some 5.3.0 or 5.2.1 in the next weeks once we have 
this MR or another fix merged (5.3 as one could consider that those Qt >= 5.14 
compatible new API a feature addition), to help all the Grantlee consumers on 
their current Qt usage modernization path, preparing for Qt6 :)
If you don't have time, please tell me, I would be happy to help out with any 
Grantlee release work needed.

Cheers
Friedrich

PS: Looking forward to 2021 and the assumed mid-year KF6 preparations, to 
finally do the planned KDEFrameworkization of Grantlee :)




More information about the kde-devel mailing list