Problem compiling KTechlab

Ralf Habacker ralf.habacker at
Thu Nov 17 08:59:58 CET 2005

Am Freitag, 11. November 2005 10:33 schrieb Rubén Usamentiaga:
> Hello I tried to compile this program under cygwin (after installing all
> the necessary libraries) and I had some problems.
> Firstly I tried ./configure and I get this error:
> checking if UIC has KDE plugins available... no
> configure: error: you need to install kdelibs first.
> Looking through internet I didn’t found a fix for this problem more than
> editing the configure script. Doing this, configure works but when you try
> to make the program you get lot of errors. I think there is something wrong
> with the uic plugin support for kde so probably editing configure is not
> the solution.
> The next thing I tried was to use unsermake. I installed unsermake,
> adjusted the $PATH and did unsermake -f Makefile.cvs. The result was:
> /home/ruf/unsermake/unsermake -f admin/Makefile.common cvs
> *** Creating acinclude.m4
> *** Creating list of subdirectories
> cd . && /home/ruf/unsermake/unsermake -f admin/Makefile.common subd
> no rule to create target: --
> Error creating ./subdirs. Exit status 1.
> Error creating cvs. Exit status 1.
> Error creating all. Exit status 1.
> Could someone give me some idea?
I have checked out recent version of ktechlab and recent version of unsermake. 
Then I have installed qt 3.3.4 in /opt/qt/3.3  and kdelibs 3.4.1 
into /opt/kde3.4 and run 

unsermake -f 


./configure --without-arts --prefix=/opt/kde3.4 --with-qt-dir=/opt/qt/3.3


More information about the kde-cygwin mailing list