Problem compiling KTechlab

Rubén Usamentiaga rusamentiaga at
Fri Nov 11 10:33:58 CET 2005

Hello I tried to compile this program under cygwin (after installing all the
necessary libraries) and I had some problems.

Firstly I tried ./configure and I get this error:

checking if UIC has KDE plugins available... no
configure: error: you need to install kdelibs first.

Looking through internet I didn’t found a fix for this problem more than
editing the configure script. Doing this, configure works but when you try
to make the program you get lot of errors. I think there is something wrong
with the uic plugin support for kde so probably editing configure is not the

The next thing I tried was to use unsermake. I installed unsermake, adjusted
the $PATH and did unsermake -f Makefile.cvs. The result was:

/home/ruf/unsermake/unsermake -f admin/Makefile.common cvs
*** Creating acinclude.m4
*** Creating list of subdirectories
cd . && /home/ruf/unsermake/unsermake -f admin/Makefile.common subd
no rule to create target: --
Error creating ./subdirs. Exit status 1.
Error creating cvs. Exit status 1.
Error creating all. Exit status 1.

Could someone give me some idea?

Thanks in advance.

More information about the kde-cygwin mailing list