FW: Question about QT

Ralf Habacker ralf.habacker at freenet.de
Fri Oct 22 02:53:35 CEST 2004

On Tuesday 19 October 2004 20:25, Yaakov Selkowitz wrote:
> Chris January wrote:
> |>Hi,
> |>I'm trying to use the Qt 3.2 X11 version of qt with cygwin
> |>with the open Gl module. I downloaded the source on the
> |>sourceforge site and compile it on my computer but i can't
> |>launch any program because of the 0x00000005 error. So do you
> |>know where i can get a version of qt 3.2 X11 with open gl or
> |>how can i compil it. I tried to use
> |>http://kde-cygwin.sourceforge.net/install
> |>with the setup file but it seams that there isn't the open gl
> |>module with the qt package.
> I presume you tried to compile this with gcc-3.3.3-3 (the current Cygwin
> release).  I believe this "feature" may be a backport from gcc-3.4; in
> short, functions defined as struct const cause this, and in the case of
> Qt, not only does the original source need to be edited, but also moc to
> prevent it from generating such code.
> I've been trying to build qt-3.3.3 from source and have some of the
> programs working, 
To be sure, you are using gcc 3.4  ? And you haven't the 0xc0000005 error ? 
This is very interesting to hear because I'm searching for a solution for this 
annoying bug. 


More information about the kde-cygwin mailing list