FW: Question about QT

Yaakov Selkowitz yselkowitz at users.sourceforge.net
Tue Oct 19 20:25:06 CEST 2004

Hash: SHA1

Chris January wrote:
|>I'm trying to use the Qt 3.2 X11 version of qt with cygwin
|>with the open Gl module. I downloaded the source on the
|>sourceforge site and compile it on my computer but i can't
|>launch any program because of the 0x00000005 error. So do you
|>know where i can get a version of qt 3.2 X11 with open gl or
|>how can i compil it. I tried to use
|>with the setup file but it seams that there isn't the open gl
|>module with the qt package.

I presume you tried to compile this with gcc-3.3.3-3 (the current Cygwin
release).  I believe this "feature" may be a backport from gcc-3.4; in
short, functions defined as struct const cause this, and in the case of
Qt, not only does the original source need to be edited, but also moc to
prevent it from generating such code.

I've been trying to build qt-3.3.3 from source and have some of the
programs working, but when I launch the programs, I get the following

QPixmap::fromMimeSource: Cannot find pixmap "images/appicon.png" in the
mime source factory

and images within the program (toolbar icons, etc.) aren't there.

I've asked for this before, but it would be really nice if someone here
(who certainly knows Qt much better than I) would prepare a new release
of Qt.

Version: GnuPG v1.2.4 (Cygwin)
Comment: Using GnuPG with Thunderbird - http://enigmail.mozdev.org


More information about the kde-cygwin mailing list