Help needed kde-devel 3.1.1

Ralf Habacker Ralf.Habacker at
Mon Aug 4 22:27:38 CEST 2003


> Thanks Ralf, I have started working my way through this process and have
> built qt3.  I am now completely stuck with glib-2.2.1.  I get this error:
> /bin/bash ../libtool --mode=link gcc-2 -g -O2 -Wall -o
> -rpath /opt/gtk/lib -version-info
> 200:1:200 -export-dynamic -no-undefined gboxed.lo gclosure.lo genums.lo
> gobject.lo gparam.lo gparamspecs.lo gsignal.lo gsourceclosure.lo gtype.lo
> gtypemodule.lo gtypeplugin.lo gvalue.lo gvaluearray.lo gvaluetransform.lo
> gvaluetypes.lo ../glib/ -lintl
> *** Warning: This system can not link to static lib archive
> ../glib/
> *** I have the capability to make that library automatically link in when
> *** you link to this library. But I can only do this if you have a
> *** shared version of the library, which you do not appear to have.
> I have tried searching the web and found references to this problem, which
> seems to be a known problem with cygwin/libtool. I think you have also made
> reference to it as well.  However, I haven't found the patch and I can't get
> round this,

the glib release of the kde3.1.1 devel package was a hack, which I have builded
with a libtool from the a current cygwin release and special hacking of the
libtool, so the easiest way currently is to use the relating parts of the devel

We are preparing a new buildsystem for kde/cygwin and friends base on the gentoo
buildsystem, where this problems should be solved. A initial release could be
found on

For example fetching qt3, appling all patches, compiling and installing is done
by a simple:

$ emerge qt

More information about the kde-cygwin mailing list