Compatibility problems with latest GTK+ applications

Sebastian K├╝gler sebas at kde.org
Thu May 8 13:56:01 BST 2014


On Thursday, May 08, 2014 14:39:49 Matthias Klumpp wrote:
> However, to support the cross-desktop efforts, the GNOME people should
> maybe make a few compromises (e.g. make GTK+ behave differently on
> other DEs), especially since GTK+ is not just for GNOME but also used
> by other projects.

This is actually at the root of all these problems. The GTK developers have at 
some point decided to couple the toolkit with the GNOME desktop, so GTK is -- 
in their view -- the toolkit for GNOME. It seems, the developers lost interest 
in keeping their cross-platform and cross-desktop promise. This is visible in 
other areas as well, such as theming: Theming APIs have been unstable and 
changed will-nilly for some time now, and the revolt of theme creators has 
calmed down by now (I suppose they all just walked away). I suppose this CSD 
episode will just speed up this exodus.

We might be looking at a completely different GTK here than we did a few years 
ago, and that's pretty bad news for interoperability on the freedesktop.

Cheers,
-- 
sebas

http://www.kde.org | http://vizZzion.org | GPG Key ID: 9119 0EF9




More information about the kde-core-devel mailing list