New framework to review: KPackage

David Edmundson david at
Wed Dec 10 14:14:01 GMT 2014

‚ÄčThe binary is called kpackagetool. Given the complications we've had with
frameworks co-installability does it make sense to call it kpackagetool5?

The class name in kpackagetool/kpackagetool.cpp should probably be renamed

Documentation at the top of PackageLoader should avoid saying Plasma quite
so much

commented line at 773 of package.cpp looks concerning. I think it is just
dead code.

Installation command of plasmoids.knsrc are wrong (in fact they're wrong
for current plasmapkg)
Should kpackage even be providing this file? I think it should be with the
plasmoid definition.

IMHO PackageJob probably shouldn't set a parent to the packagestructure.
Otherwise if you create a PackageStructure on the stack then call
install/uninstall it will delete the job before it's finished.

 There's a Qt5 TODO on PackageJobThread::removeFolder
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>
-------------- next part --------------
Kde-frameworks-devel mailing list
Kde-frameworks-devel at

More information about the kde-core-devel mailing list