kde review kartesio

Sven Brauch svenbrauch at googlemail.com
Fri May 10 16:04:04 BST 2013


Hi Luca,

> Yes, the correct way to express a power is ^. So you should write x^2.
I figured that after it had crashed ;)

> There should be a check routine to avoid that a dangerous string like
> "**" is used, and I'm surely integrating this check in the next release.
In my opinion you should not release your application with such an
obvious crash bug. It's not only this expression, the program crashes
whenever there is anything wrong in that text field. That's not
something you can defer to the next release.

> Actually there is not: I'm working on a new window for the next releases:
> basically, there will be a button over the table, something like "Edit datas".
> This will open a new window in which it will be possible to import/export CSV,
> sort X axis values, add other rows or deleting some...
I don't know if it makes sense, but you should have a look at the
calligra sheets part (aka talk to someone who knows about it).
Eventually that can be very useful for this purpose (unfortunately I
don't know exactly how they work).

> Could this instruction be shorter and more elagant? Probably. But it works,
> and actually I think it could stay as it is.
You could replace a 2000+ character boolean logic expression which
lists all the letters in the alphabet by this:
  c.isLetter() || QString("+-*/^").contains(c)
at least assuming you do the other thing I said and use QString
instead of char*.
This is a cleanup which is worth doing.

> I know it, I'll try to make the code more readable, but I do not have so much
> time so usually I prefer to dedicate my time to new features or corrections
> instead of making them prettier.
Writing correctly formatted code is mostly a matter of setting up your
editor correctly. Spend five minutes doing that ;)

Greetings,
Sven




More information about the kde-core-devel mailing list