Requiring cmake 2.8.9 for kdelibs 4.10 ?
steveire at gmail.com
Mon Oct 1 08:53:22 BST 2012
>> So from the building kde stuff point of view it should be relatively
>> painless, and we free ourselves from the silly restrictions we have by
>> having CMake 2.8.6 as the minimum required version,
> We're at 2.6.4 ;-)
Yes, sorry. Typod.
>> such as not being able to use CMAKE_CURRENT_LIST_DIR etc.
We should update the CMake dependency now because updating it is so overdue.
I don't think updating now for the features in 2.8.10/9 makes sense, because
it would make more sense to update to 2.8.11 as I outlined in my previous
So if we do one 'painful' update to 2.8.9 now, we'll do another 'painful'
update to 2.8.11 later.
Instead, I say we should do a 'pain free' update to 2.8.7 now, and an update
to 2.8.11 later. Whether that update needs to be 'painful' or not remains to
I also think 2.8.8 is good, but if we update to that, lots of people will
notice. If we update to 2.8.7, far fewer people, if any, will notice.
More information about the kde-core-devel