hard-dep for Qt 4.8

Sebastian K├╝gler sebas at kde.org
Fri Jan 13 11:46:46 GMT 2012


On Wednesday, January 11, 2012 17:47:00 Shaun Reich wrote:
> Prompting motion for making Qt 4.8 a hard dependency for KDE
> 4.9/master. Currently kde-baseapps/plasma/folderview does not build
> against 4.7 due to an (albeit minor) api usage.
> 
> Not sure how other areas in KDE fair against this, most notably the
> Plasma area (with QML and what not).
> 
> If we depend on it, we need to set the CMake check obviously.

So the verdict would be: 4.8 is recommended (for all its improvements, fixes 
and better performance), but hard build dependencies in the source code on Qt 
4.8 are not allowed, until further notice.

Developers are encouraged to use Qt 4.8 for development.

This only applies to the KDE/4.8 branches. It would be nice, however, if kde-
baseapps/plasma/folderview from master could be made to work with Qt 4.7. 
(Therefore, CC:ing plasma-devel.)

Cheers,
-- 
sebas

http://www.kde.org | http://vizZzion.org | GPG Key ID: 9119 0EF9



More information about the kde-core-devel mailing list