Moving libmm-qt and libnm-qt to kdereview
zander at kde.org
Sun Dec 4 21:18:07 GMT 2011
On Sunday 04 December 2011 15.15.23 Lamarque V. Souza wrote:
> Em Sunday 04 December 2011, Aaron J. Seigo escreveu:
> > On Saturday, December 3, 2011 17:48:17 Lamarque V. Souza wrote:
> > > https://projects.kde.org/projects/playground/base/libmm-qt
> > > https://projects.kde.org/projects/playground/base/libnm-qt
> > i know its relatively late to bring this up, but better before a first
> > initial release to do so: is there any chance that these libraries could
> > get more descriptive names?
> > there is already a "libmm" which is actually a shared memory helper,
> > unrelated to libmm-qt (though the name suggests otherwise). "mm" and "nm"
> > really don't say much about what these libraries do. the names are
> > ambiguous and stand a high chance of collision with other libraries.
> > i know that the networkmanager project decided to call their library
> > libnm, but we don't need to repeat such errors ourselves, right? :)
> Well, the final goal is to move those two libraries to ModemManager and
> NetworkManager's repositories in the future. If I rename them now I will
> probably have to rename them back in the future. I think will have to ask
> this to NetworkManager guys now.
> What names do you suggest? libmodemmanager-qt and libnetworkmanager-qt?
> I do not see any other more descriptive name. Another suggestion is
> libQtModemManager and libQtNetworkManager, which follows Qt's library name
> convention. I think will stick to the latter. Just let me check with the
> NetworkManager guys if there is any problem using Qt's library name
> convention instead of NM"s.
first sorry for the noisy '+1' email, seems I was impatient and your email was
stuck in the moderation queue :)
I just wanted to mention that in general longer library names are a real big
help for avoiding problems, like Aaron suggested. If the network manager
people tell you you should make it essentially an abbreviation it would be bad
for a couple of reasons. Mostly the reasons suggested above :)
It would be good to start with the names as you suggest, and I personally have
no preference between the lowercase and the mixed-case ones.
Lets start with a descriptive and clear name, to raise the bar.
More information about the kde-core-devel