Review Request: Adding "net usershare" suport for KSambaShare
Rodrigo Belem
rclbelem at gmail.com
Wed Nov 17 00:51:06 GMT 2010
> On 2010-11-15 21:49:42, David Faure wrote:
> > /trunk/KDE/kdelibs/kio/kio/ksambashare.cpp, line 93
> > <http://svn.reviewboard.kde.org/r/4320/diff/13/?file=41345#file41345line93>
> >
> > To keep the C++ code maintainable and modular, please declare and use variables in the same line, e.g.
> >
> > QString rawString = testparmParamValue(...);
> >
> > Then you can even make it const to indicate that it's not modified anywhere in the method.
> >
> > const QString rawString = testparmParamValue(...);
> >
> > ("parmParam? That's a bit difficult to read, don't both words mean "parameter"?)
I called testparmParamValue because the application is called testparm.
> On 2010-11-15 21:49:42, David Faure wrote:
> > /trunk/KDE/kdelibs/kio/kio/ksambashare.cpp, line 64
> > <http://svn.reviewboard.kde.org/r/4320/diff/13/?file=41345#file41345line64>
> >
> > Please keep the original solution of static const char* const ... []. It made the data really-const (.rodata section), i.e. shared between processes and not relocated in memory.
Can we remove this method? It will not be used anymore.
> On 2010-11-15 21:49:42, David Faure wrote:
> > /trunk/KDE/kdelibs/kio/kio/ksambashare.h, line 106
> > <http://svn.reviewboard.kde.org/r/4320/diff/13/?file=41344#file41344line106>
> >
> > Why did you move away from Q_PRIVATE_SLOT? This looks like a step in the wrong direction.
I think that we can remove this slot.
- Rodrigo
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
http://svn.reviewboard.kde.org/r/4320/#review8750
-----------------------------------------------------------
On 2010-11-17 00:46:45, Rodrigo Belem wrote:
>
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> http://svn.reviewboard.kde.org/r/4320/
> -----------------------------------------------------------
>
> (Updated 2010-11-17 00:46:45)
>
>
> Review request for kdelibs, Raphael Kubo da Costa, Jonathan Thomas, Aurélien Gâteau, Jonathan Riddell, Adenilson Cavalcanti, loureiro, and Daniel Nicoletti.
>
>
> Summary
> -------
>
> KDE needs to support modern samba tools. With the "net usershare" command line tool the users can manage their shares. The attached patch intends to add support for this tool.
>
>
> Diffs
> -----
>
> /trunk/KDE/kdelibs/includes/CMakeLists.txt 1180108
> /trunk/KDE/kdelibs/kio/CMakeLists.txt 1180108
> /trunk/KDE/kdelibs/kio/kio/ksambashare.h 1180108
> /trunk/KDE/kdelibs/kio/kio/ksambashare.cpp 1180108
> /trunk/KDE/kdelibs/kio/kio/ksambashare_p.h PRE-CREATION
> /trunk/KDE/kdelibs/kio/kio/ksambasharedata.h PRE-CREATION
> /trunk/KDE/kdelibs/kio/kio/ksambasharedata.cpp PRE-CREATION
> /trunk/KDE/kdelibs/kio/kio/ksambasharedata_p.h PRE-CREATION
>
> Diff: http://svn.reviewboard.kde.org/r/4320/diff
>
>
> Testing
> -------
>
>
> Thanks,
>
> Rodrigo
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kde-core-devel/attachments/20101117/b294a330/attachment.htm>
More information about the kde-core-devel
mailing list