Review Request: Displaying Job Progress in Icons - Review Request
David Faure
faure at kde.org
Tue Feb 23 16:58:18 GMT 2010
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
http://reviewboard.kde.org/r/2057/#review4255
-----------------------------------------------------------
Ship it!
Looks good to me now, I think this can go in (just 2 minor things found).
But hmm, this diff (r4) only includes kio it seems, wasn't there stuff in kdeui too?
Feel free to commit the kio bits, in any case.
/trunk/KDE/kdelibs/kio/kio/kdirmodel.cpp
<http://reviewboard.kde.org/r/2057/#comment3775>
m_ prefix missing, to match the other member vars
/trunk/KDE/kdelibs/kio/kio/kdirmodel.cpp
<http://reviewboard.kde.org/r/2057/#comment3776>
the SLOT() signature can also use QStringList (no const ref) to make it simpler.
- David
On 2010-02-14 06:28:50, Shaun Reich wrote:
>
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> http://reviewboard.kde.org/r/2057/
> -----------------------------------------------------------
>
> (Updated 2010-02-14 06:28:50)
>
>
> Review request for kdelibs.
>
>
> Summary
> -------
>
> Hello,
>
> This merge request is for the changes I have done (on my branch), along with other changes(but those are just waiting for this review).
>
> The branch was for a project that I have done; displaying the job progress on the file/folder icons. It essentially shows the status, as in whether or not there is a job being performed on a certain dest. url, if there is, a download icon will be shown at the corner, with an animation(circles rotating around a focal point), to show that a transfer is happening (download, copy, etc..).
>
> It should be pretty subtle, but may need some tweaking.
>
>
> I don't really like the KDirModel::setDisplayJobTransfers(bool), and KFileItemDelegate::setDisplayJobTranfers(bool). They sound terrible imo, and seem to go against Nice API Design, but I use them for lack of a better name. Hopefully you guys have some suggestions?
>
> Naturally those 2 method properties are off by default, the individual apps should turn it on at their discretion. I will probably do that for Dolphin and the Folderview plasmoid.
>
>
> There was some oddity that I experienced, that seemed like an impossibility (then again, lots of bugs do). It wouldn't stop displaying that a job was happening, but I tracked it down and if anything it would have been the sender (kuiserver)'s issue. But I've tested kuiserver quite rigorously...I'm thinking it is just some problem dealing with the *major* version differences I am running.. *shrug*
>
>
> I can no longer test this branch with my system, as I run trunk and running this really old checkout side by side...well, that was a pain I am not going to go through again, as apps were crashing so often etc.. and I *still* don't have my plasma's desktop activities back up and running, only 2 system monitors on the desktop :)
>
>
> Once it's committed to trunk, I should be able to quickly verify and track down any issues...
>
>
> Diffs
> -----
>
> /trunk/KDE/kdelibs/kio/kio/kfileitemdelegate.cpp 1089795
> /trunk/KDE/kdelibs/kio/kio/kfileitemdelegate.h 1089795
> /trunk/KDE/kdelibs/kio/kio/kdirmodel.cpp 1089795
> /trunk/KDE/kdelibs/kio/kio/copyjob.cpp 1089795
> /trunk/KDE/kdelibs/kio/kio/delegateanimationhandler.cpp 1089795
> /trunk/KDE/kdelibs/kio/kio/delegateanimationhandler_p.h 1089795
> /trunk/KDE/kdelibs/kio/kio/job.cpp 1089795
> /trunk/KDE/kdelibs/kio/kio/kdirmodel.h 1089795
>
> Diff: http://reviewboard.kde.org/r/2057/diff
>
>
> Testing
> -------
>
> oodles.
>
>
> Thanks,
>
> Shaun
>
>
More information about the kde-core-devel
mailing list