is ccache working?

Michael Zanetti michael_zanetti at
Sun Aug 1 12:56:22 BST 2010

On Sunday 01 August 2010 13:36:22 fabio de francesco wrote:
> On Sunday 01 August 2010 13:27:03 Michael Zanetti wrote:
> > It's been a while since I last used gentoo, but IIRC you need to enable
> > ccache in your PATH to be used system-wide. Enabling it in make.conf only
> > enables it for portage.
> > 
> > The handbook seems to confirm that:
> >
> > 
> > 
> > Hope that helps,
> > Michael
> Please, re-read my latest post. I've made symlinks in ~/KDE/bin (that is
> the first in $PATH for the user but it is still not working.

Try changing your path for user kdevel to this:


I guess the two symlinks for g++ and gcc aren't enough. Depending on your 
system, make usually calls something like x86_64-unknown-linux-gnu-cpp. You 
should either make symlinks for all files in /usr/lib/ccache/bin/ or simply 
change your path according to the handbook.

If this still doesn't help, try compiling a file manually and see if ccache 

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 198 bytes
Desc: This is a digitally signed message part.
URL: <>

More information about the kde-core-devel mailing list