Merging KAuth into KDELibs

Christoph Feck christoph at
Mon Sep 28 21:09:14 BST 2009

On Monday 28 September 2009 21:47:44 Dario Freddi wrote:
>  [...] since KAuthorized instead of KAuthorize makes not much sense to me

Hm, KAuthorized::Action certainly makes more sense than KAuthorize::Action :)

Actually, do we need a namespace at all? There are only four public classes, 
and the amount of name referencing is quite minimal, you generally would not 
need to use the "using namespace KAuth;" to import the module, but mention the 
namespace explicitely.

I would just go for class KAuthorizedAction, as that is the "central" class, 
and the others would be subclasses of that (KAuthorizedAction::Reply, 

My 10 dollars only...

More information about the kde-core-devel mailing list