Merging KAuth into KDELibs

Parker Coates parker.coates at
Mon Sep 28 17:43:30 BST 2009

On Mon, Sep 28, 2009 at 09:47, David Jarvie wrote:
> On Monday 28 Sep 2009 14:07:52 Dario Freddi wrote:
>> On Saturday 26 September 2009 00:17:28 Friedrich W. H. Kossebau wrote:
>>> Or even better, create a non-generic name for this, cmp. Sonnet, Phonon,
>>>  etc.
>>> Something with Direttiva or similar perhaps...
>> I really like Direttiva as a name. Would that be fine even if it's inside
>> kdecore? (eg kdelibs/kdecore/direttiva)
> IMO, for small modules, it is much better to use names which reflect the
> contents. Using names like Phonon etc. is fine for major modules which
> everybody is aware of and which KDE wants to create publicity about, but for
> things like KAuth/KAuthorization it just makes things obscure for no obvious
> gain. Reading code which refers to a class 'Direttiva' doesn't really give
> much clue as to what it's about, unless you already know the name. It's a good
> way of raising the barrier for new people getting into KDE coding.

I was writing an email along similar lines, when David's showed up. :)

Cool names are cool for major platforms that want some branding. No
offense, but from what I understand, KAuth doesn't really fall into
that category. It's a rather small developer API meant to do one or
two things and do them well. An informative name like KAuthorization
is likely to serve it better.

Of course, that's just my opinion.


More information about the kde-core-devel mailing list