kWarning() broken!

Andreas Pakulat apaku at
Fri Sep 18 08:39:29 BST 2009

On 18.09.09 02:40:40, Milian Wolff wrote:
> Hey people!
> Something makes kWarning() output _nothing_ at all.
> I just spent 2h debugging a problem in the PHP plugin to finally find it and saw 
> that I _should_ have seen it directly: there should have been a kWarning() 
> message emitted.
> I deleted my kdebugrc, enabled _all_ areas in kdebugdialog, no change. Also 
> note: kDebug() works just fine!
> I tried around, didn't work in any kdevelop plugin. Also added it to a 
> KTextEditor plugin, which showed the same behaviour...
> Can someone reproduce this issue or is it something local on my machine?
> Oh and note: In a simple hello-world-like app kWarning worked just fine!
> Do you have an idea what might be the issue?
> I find this very critical as kWarnings should _always_ be shown! Right now it's 
> really the worst-case scenario...

Are you running trunk? I won't have access to a 4.3 system until next
week, but it could be that this is a regression introduced by dfaure's

I could just reproduce this with kcalc, using kWarning() didn't produce
anything. It seems kcalc gets assigned an automatic id here though. Even
if I explcitly put in a static debug area and enable that it doesn't

I'm moving this to kde-core-devel (please remove kwrite-devel when
replying) as thats where this belongs. I've seen this also in QTest
unit-tests, kDebug() was printed, but kWarnings() are not.


You will experience a strong urge to do good; but it will pass.

More information about the kde-core-devel mailing list