Merging KAuth into KDELibs

Aaron J. Seigo aseigo at
Sat Sep 12 15:51:51 BST 2009

On September 12, 2009, Ingo Klöcker wrote:
> KAuthorized is a bad name in itself because "authorized" is an
> adjective. IMO we should use nouns for namespaces and class names, e.g.
> KAuthorization or KAuthority (or something else, see below).


> On Monday 07 September 2009, Aaron J. Seigo wrote:
> > > KAuthorized is a nice, simple interface for an
> > > app to ask "should this app show and allow this kind of action?"
> KAllowance or KPermission? Yes, I know that this cannot be changed
> before KDE 5.

yes, something to be revisited then.

> Having two namespaces KAuthorization and KAuthorized is surely not more
> confusing than having two namespaces KAuth and KAuthorized.

i think it's actually less confusing. +1 for KAuthorization.

Aaron J. Seigo
humru othro a kohnu se
GPG Fingerprint: 8B8B 2209 0C6F 7C47 B1EA  EE75 D6B7 2EB1 A7F1 DB43

KDE core developer sponsored by Qt Development Frameworks
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 197 bytes
Desc: This is a digitally signed message part.
URL: <>

More information about the kde-core-devel mailing list