Review Request: Add accessors for Solid Predicate internals previously only exposed in ctor's

Kevin Ottens ervin at kde.org
Tue Sep 8 15:52:21 BST 2009


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
http://reviewboard.kde.org/r/1491/#review2268
-----------------------------------------------------------

Ship it!


A couple more comments. Mostly APIDOX related, and a couple of renames in the new enum. Please address them and then feel free to commit.


/trunk/KDE/kdelibs/solid/solid/predicate.h
<http://reviewboard.kde.org/r/1491/#comment1573>

    What about:
     - s/AtomType/PropertyCheck/
     - s/AndType/Conjunction/
     - s/OrType/Disjunction/
     - s/IsType/InterfaceCheck/
    
    This way the code would read:
    p.type()==Predicate::PropertyCheck
    or
    p.type()==Predicate::Conjunction
    
    It's probably more readable I guess.



/trunk/KDE/kdelibs/solid/solid/predicate.h
<http://reviewboard.kde.org/r/1491/#comment1567>

    Please clarify in the APIDOX that it is valid only for AtomType and IsType



/trunk/KDE/kdelibs/solid/solid/predicate.h
<http://reviewboard.kde.org/r/1491/#comment1568>

    Same comment but for AtomType only.



/trunk/KDE/kdelibs/solid/solid/predicate.h
<http://reviewboard.kde.org/r/1491/#comment1569>

    Again... :-)



/trunk/KDE/kdelibs/solid/solid/predicate.h
<http://reviewboard.kde.org/r/1491/#comment1570>

    And again... :-)



/trunk/KDE/kdelibs/solid/solid/predicate.h
<http://reviewboard.kde.org/r/1491/#comment1571>

    Please indicate that this one is valid only for OrType and AndType.



/trunk/KDE/kdelibs/solid/solid/predicate.h
<http://reviewboard.kde.org/r/1491/#comment1572>

    Obviously same as above.


- Kevin


On 2009-09-03 06:57:27, Ben Cooksley wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> http://reviewboard.kde.org/r/1491/
> -----------------------------------------------------------
> 
> (Updated 2009-09-03 06:57:27)
> 
> 
> Review request for kdelibs and Kevin Ottens.
> 
> 
> Summary
> -------
> 
> Adds accessors for internal objects previously exposed in ctor's, and the OperatorType enum.
> This allows applications such as the Device Actions KCM to share the same parsing implementation as libsolid and prevents code duplication, etc.
> 
> 
> Diffs
> -----
> 
>   /trunk/KDE/kdelibs/solid/solid/predicate.h 1018534 
>   /trunk/KDE/kdelibs/solid/solid/predicate.cpp 1018534 
> 
> Diff: http://reviewboard.kde.org/r/1491/diff
> 
> 
> Testing
> -------
> 
> Compiles.
> 
> 
> Thanks,
> 
> Ben
> 
>





More information about the kde-core-devel mailing list