KNotificationItem specification - first draft

Aurélien Gâteau aurelien.gateau at
Mon Sep 7 10:36:43 BST 2009


I am probably a bit late at this, but thought I would ask anyway.

Why did you choose the term "KNotificationItem"? I am afraid this is 
going to cause confusion with the existing notification systems.

A name like KSystemTrayItem would avoid such confusions. I know it is 
probably not very appropriate because it describe a visualization rather 
than the content, but I feel it would still be better than 
KNotificationItem (Think about a new developer faced with choosing 
between the KNotification and KNotificationItem classes...)


PS: To get more feedback about the spec, I suggest you generate an html 
output of it and upload it somewhere.

More information about the kde-core-devel mailing list