KNotificationItem class name is confusing

Parker Coates parker.coates at
Wed Oct 28 20:58:35 GMT 2009

On Wed, Oct 28, 2009 at 16:03, Aaron J. Seigo wrote:
> possible names that would be both accurate and meaningful might
> include KApplicationStatusNotifier, KStatusNotifier, KStatusNotificationItem

All of these have an advantage over the current name by putting
something between the "K" and the "Notificaton". That greatly serves
to break the immediate mental connection to KNotification.

I assumed that anything containing "application" was off limits as
many systray users are services, not applications.

> i'm not sure using the term "Workspace" in there makes much sense.

Can I ask why you don't think "workspace" makes sense? I thought it
was important to recognise that this "item" lives outside of the
application itself. Sticking "workspace" in there was the best I could
come up with to indicate that.

> as a side note, it would be great if we could make this the last thread on
> this matter. it is far from the first and i'm confident we have better things
> to do than rehash this conversation repeatedly.

I think everyone agrees with you there. Who makes the final call? Marco?

(Whose opinion matters less than Kevin's)

More information about the kde-core-devel mailing list