KNotificationItem class name is confusing

Marco Martin notmart at
Wed Oct 28 13:36:20 GMT 2009

On Wednesday 28 October 2009, Aurélien Gâteau wrote:
> Hi,
> At the risk of starting yet another lengthy discussion, I would like to
> bring this to the list. As you probably know, kdelibs 4.4 will ship with
> KNotificationItem, a class wrapping the brand new dbus-based
> implementation of the systemtray protocol, saving us from the wrath of
> X-Embed.
> This new protocol is really an improvement over the existing one, but I
> believe the class name is wrong as people think KNotificationItem is
> about notifications. This is worsened by the fact that kdelibs also
> features a KNotification class, which manages notifications. Many times
> I had to explain people this new protocol and classes are not about
> notifications.

it is.
one idea is that if the app has nothing to notify it should not show anything

> Some discussion about this on the xdg@ list didn't get much following,
> but what came out though is that the name was difficult to choose and
> developers settled on KNotificationItem in the end because both Windows
> and GNOME refer to the systray as the "Notification Area".
> This got me thinking about potential, less confusing, names. So I would
> like to present some ideas I got (hopefully a bit less lame than the one
> I posted on xdg@):
> - KNotificationAreaItem: This is consistent with the fact that these are
> items from the "Notification Area". Still it contains the word
> Notification, which I do not believe should be there.

it had that name in the past, was renamed (lost the count on how many times 
renamed) because it's not sure that the item will go in any "area" in 

> - StatusAreaItem: I thought about this one when I read a post about the
> work done by Fedora people on systray icons [1]. In this post they call
> the icons "status icons".
> What do you think? Is it too late? Am I just a painful nit-picker? Do
> you have better ideas?

i honestly think this has more to do with notifications rather than a 
"systemtray", that some day could hopefully go away altogether

> Aurélien
> [1]

Marco Martin

More information about the kde-core-devel mailing list