KNotificationItem class name is confusing

Kevin Ottens ervin at
Wed Oct 28 13:20:34 GMT 2009


On Wednesday 28 October 2009 14:08:54 Aurélien Gâteau wrote:
> I like it, but it's a bit long. Maybe "Persistent" could be removed?
> KWorkspaceStatusItem sounds better to me.

I think it's my favorite proposal so far. Doesn't clash with "notification" 
naming, and convey what it is (workspace wide status) without attaching itself 
to a mean of displaying it (and then an implementation detail).
Not that my opinion matters a lot on this particular area but I give it 
anyway. :-p

My 0.02€.

Kévin Ottens,

KDAB - proud patron of KDE,
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 197 bytes
Desc: This is a digitally signed message part.
URL: <>

More information about the kde-core-devel mailing list