KEncodingProber that might be useful for 4.2.2

Peter Oberndorfer kumbayo84 at
Tue Mar 24 21:51:58 GMT 2009

like mentioned in my last patch for "Patch: Fix KEncodingProber crashiness"
i have a patch that might be a good idea for 4.2.2

It renames encodingNameByteArray() to encoding() as suggested by David Faure,
fixes a few comments in the header, adds a @since
and restores the function of encodingName() !
So programs not ported to the new API do not see any breakage compared with 4.2.1

The only current user i know about is katebuffer.cpp
(which is included in this patch)
amarok, which also uses KEncodingProber only uses the old encodingName()
(which is now depecated/(and more or less broken since it always returns 0 without this patch)

Rename encodingNameByteArray() to encoding()
Make the old encodingName() function return a useful value again
Fix some typos in documentation
Add @since 4.2.2 to the new encoding() function

If anybody wants to see this in 4.2.2, now seems to be the very last chance before
we are stuck with encdingNameByteArray() name.

If anybody wants to apply it please apply to 4.2.2 and 4.3(trunk)

Greetings Peter
-------------- next part --------------
A non-text attachment was scrubbed...
Name: f41105d4b61b3e393fb734b93825e3f9629205b0.diff
Type: text/x-diff
Size: 3913 bytes
Desc: not available
URL: <>

More information about the kde-core-devel mailing list