Aaron J. Seigo
aseigo at kde.org
Tue Apr 21 00:32:35 BST 2009
On Monday 20 April 2009, Olivier Goffart wrote:
> Le Mandag 20 april 2009, Aaron J. Seigo a écrit :
> > questions, comments are desired.
> I am questioning the name "KNotificationAreaItem". I think it is
> confusing regarding KNotification.
we wracked our brain over this for quite some time... we picked this because:
* it doesn't say "system tray" (see below for more on this)
* "notification area" is actually a fairly common name for this thing, e.g.
it's the term Microsoft uses (ok, that's a weak reason ;)
* the emphasis is on notifying the user about things: there are balloons,
statuses, etc. in fact i almost wonder that if the xembed approach hadn't been
there first if these items would have ended up in knotify in the _first_ place
:) it just makes so much more sense, really, given the usage scenarios for
them (and why people get so confused as to when to use visual notfications,
system tray icons, OSDs .. where to place logging facilities, etc...)
so while it is a bit messy with regards to KNotification, it's accurate.
if you have a better name, though, i'd be _happy_ to have it .. now's the time
to do it :)
> I guess this is intentional not to call it "KSystemTrayItem" ?
yes, since these items may not appear in a "system tray" at all.
the items may (and will in future) appear as part of taskbar entries or in a
messaging area (for the messaging entries). we're trying to tame the system
tray by getting rid of the "system tray" itself as much as possible while
keeping the UI bits in place, and this a step towards that. (though, of
course, we can also keep the 25 icons in a bunch tray concept too at the same
part of the goal is to break application developers of thinking "oh look, i'm
putting a little icon in this little overcrowded spot of my desktop. i know
exactly how this will look and behave." and instead think "here's the set of
data that describes the communication i want to make to the user"
> But maybe KNotification itself yould be deprecated and renamed
> KNotificationEvent or KEventNotification or something. (but i don't think
> changing its api now would be a smart move)
i don't think KNotification should be touched at all this point (name or API).
but for KDE5 (far into the future one hopes) i think naming it something
slightly less ambiguous would be good :)
(i'll make sure that if the names stay that same that appropriate information
exists in the apidox of the relevant classes about the role they play visa-vis
Aaron J. Seigo
humru othro a kohnu se
GPG Fingerprint: 8B8B 2209 0C6F 7C47 B1EA EE75 D6B7 2EB1 A7F1 DB43
KDE core developer sponsored by Qt Software
-------------- next part --------------
A non-text attachment was scrubbed...
Size: 197 bytes
Desc: This is a digitally signed message part.
More information about the kde-core-devel