Andreas Pakulat apaku at gmx.de
Wed Apr 8 08:17:13 BST 2009

On 07.04.09 21:21:47, Raphael Kubo da Costa wrote:
> 2009/4/7 Andreas Pakulat <apaku at gmx.de>:
> > On 07.04.09 21:12:30, Raphael Kubo da Costa wrote:
> >> SVN commit 950837 by rkcosta:
> >>
> >> Make killJob a private slot.
> >
> > Shouldn't it rather be Q_PRIVATE_SLOT(d,_k_killJob()) and then the
> > _k_killJob method would be a member of the Private class?
> I don't know. Would it make any difference?

Yes, because that allows to rename/remove the slot without breaking binary
compatibility, while with the current private slot you can't ever change
the slot in any way.

> Besides: should it really be private?

Thats something that David or Kevin have to answer.


Your present plans will be successful.

More information about the kde-core-devel mailing list