patches for custom styleelements, kcapacitybar

Thomas L├╝bking thomas.luebking at
Fri Oct 24 21:50:56 BST 2008

Am Friday 24 October 2008 schrieb Maksim Orlovich:
> I don't think the ID lookup methods should be named styleHint, etc., since
> [...]
> QPalette for a particularly bad instance). May be queryStyleHintId or
> such? (I kind of suck at naming).
I chose customStyleHint() etc. - has the advance of a coherent beginning and i 
(personally) don't like "query" or "get" functions too much (unless you query 
a dbase or get files via a network, of course)

A second change is QHash as replacement for QMap, as in the current 
implementation, we'll most probably (hopefully ;-) cross the 10 elements mark 
pretty soon.

I also went through the comments (fixing at least some typos...) and API docs - 
clarifying the relevance of the "CE_" etc. token and commented on abuse of 
custom elements (i'd prefer too keep an example for the app as imho examples 
are easier to understand and systematize than generic explanations - but 
obviously i don't mind if you remove it)


-------------- next part --------------
A non-text attachment was scrubbed...
Name: customelements.kcapacitybar.diff
Type: text/x-patch
Size: 1988 bytes
Desc: not available
URL: <>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: customelements.kstyle.diff
Type: text/x-patch
Size: 9949 bytes
Desc: not available
URL: <>

More information about the kde-core-devel mailing list