patches for custom styleelements, kcapacitybar

Maksim Orlovich mo85 at
Fri Oct 24 18:54:36 BST 2008

> Nevermind - took me some time as well this time...
> Attached are new attempt patches. (The oxygen patch is still nothing but a
> proof of concept)

Now this looks very nice. Only one bit of feedback on substance:
I don't think the ID lookup methods should be named styleHint, etc., since
that's what the normal QStyle methods are, and IMHO it's a bad idea to
have overloads that do totally different things (checkout ::resolve in
QPalette for a particularly bad instance). May be queryStyleHintId or
such? (I kind of suck at naming).

Less substantially... subelementCounter should probably be
subElementCounter for consistency. There are still a bunch of typos in the
comments, but it'll probably be less work for everyone involved if you
were to commit it and I could just edit it and fix it up.

WRT to API docs, though, I strongly believe we should NOT be encouraging
applications to use non-standard widgets, so the example of
should be removed. Also, from the code the use of PE_, etc. isn't quite


More information about the kde-core-devel mailing list