move QCoreApplication::addLibraryPath call from KApplication to KComponentData

Matthias Kretz kretz at
Wed Nov 26 09:56:06 GMT 2008

On Wednesday 26 November 2008 01:09:03 David Faure wrote:
> On Monday 24 November 2008, Matthias Kretz wrote:
> > I still didn't get a "go ahead". Do you want me to change the atomic int
> > to an int? I still think the patch should go in as is.
> Personally I think this testAndSet stuff just makes this code unreadable,
> especially if we all agree that it's pointless in code that will always be
> single-threaded...
> About code readability, this int should rather be an enum, too :-)

New patch to KCD attached.

Matthias Kretz (Germany)                            <><

-------------- next part --------------
A non-text attachment was scrubbed...
Name: addLibPathsInKCD2.patch
Type: text/x-patch
Size: 2357 bytes
Desc: not available
URL: <>

More information about the kde-core-devel mailing list