move QCoreApplication::addLibraryPath call from KApplication to KComponentData

David Faure faure at
Wed Nov 26 00:09:03 GMT 2008

On Monday 24 November 2008, Matthias Kretz wrote:
> I still didn't get a "go ahead". Do you want me to change the atomic int to an 
> int? I still think the patch should go in as is.

Personally I think this testAndSet stuff just makes this code unreadable,
especially if we all agree that it's pointless in code that will always be

About code readability, this int should rather be an enum, too :-)

David Faure, faure at, sponsored by Qt Software @ Nokia to work on KDE,
Konqueror (, and KOffice (

More information about the kde-core-devel mailing list