Separating kwalletd from kded

Michael Pyne mpyne at
Sun Jun 22 04:10:54 BST 2008

On Saturday 21 June 2008, Michael Leupold wrote:
> Hi Daniel,
> Am Samstag, 21. Juni 2008 schrieb Daniel Winter:
> > On Thursday 19 June 2008 14:43:38 Michael Leupold wrote:
> > > I tried to be careful not to cause any regression but in case you find
> > > any, feel free to bug me.
> >
> > OK, I am not sure if that is something just on my side.
> > But I have rebuilt kde yesterday and now I have to start kwalletd on my
> > own to use KWallet.  Do I have to update some file ~/.kded4? If so, how
> > will that happen when an user using 4.0.x now will update to 4.1?
> It might be possible that your kded is choking on the still-exisiting
> $KDEDIR/share/apps/services/kded/kwalletd.desktop which was now moved to
> $KDEDIR/share/apps/services/kwalletd.desktop as it doesn't belong to kded
> any longer. If kbuildsycoca4 doesn't help, please try removing the old
> .desktop file manually. I hope that does the trick for you. Strange enough
> it worked for me without cleaning it...

This problem occurred for me as well, I would recommend having a way to 
automatically detect and correct this problem before 4.1.  Actually maybe not, 
this should be taken care of by proper package management in practice I think 
(although it may be worth a kError()).

In my case the files were in $KDEDIR/share/kde4/services/kded, so if you're 
doing this at home just look in `kde4-config --install 

 - Michael Pyne
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 197 bytes
Desc: This is a digitally signed message part.
URL: <>

More information about the kde-core-devel mailing list